Riskified availability issues

Incident Report for Riskified Status

Resolved

We have resolved the availability issues with our Control Center. The service is now fully operational.

Order decisions and notifications are fully functional.
Posted May 08, 2026 - 02:32 UTC

Update

The issue has been identified and resolved, while it might take some time (up-to-1-hour) to get the visibility to all those impacted orders in Control Center portal.
Posted May 08, 2026 - 02:31 UTC

Investigating

We are currently experiencing degraded performance with our order reviews and notifications due to an outage with our cloud provider.
Posted May 08, 2026 - 00:51 UTC
This incident affected: Chargeback Guarantee - Async, Chargeback Guarantee - Sync, and Control Center.